Emulator display issues...

Jul 20, 2010 at 11:58 PM

So, I'm trying to build and debug using the emulator... I've copied the libgles_cm.dll in the source package to the emulator /windows dir (tried both the WinMo 6 Classic and WinMo 6 Professional emulator so far), and even the Test demo displays things very oddly.  Seems oversized, and contorted (list items are oversized, toolbar is offset, etc.), and clicking _seems_ to basically click on something about 150 pixels _above_ where I click, and maybe 150 pixels to the left as well(?)...

All in all, I can't seem to make it work.  I've searched around and found various other copies of libgles_cm.dll that appear to be emulator compatible as well - tried several, and got either the same behavior, or the app just terminates without ever drawing a pixel...

Is there something about the WinMo 6 SDK / Emulator causing this?  Should I find a different emulator?  Has anyone gotten this working?

Coordinator
Jul 21, 2010 at 12:57 PM

honestly, I haven't used the emulator for a while, due to the lack of hardware accelerated OpenGL. I designed Silvermoon to support porth 192dpi and 96dpi (or even other), while 192dpi is the standard, but I'm not sure if the beta still handles other than 192dpi correctly.

Would be nice if you find a better emulator!

 

Jul 21, 2010 at 4:33 PM

OK... <blush>... apparently just choosing an emulator image that runs at 192 dpi does the trick.  There are definitely issues with the code running at 96 dpi, but I'll just focus on higher res stuff for now.

Thanks much for your great work on this stuff!

-adam